Modizer keeps crashing on boot - HELP! :\

classic Classic list List threaded Threaded
14 messages Options
sad_muso sad_muso
Reply | Threaded
Open this post in threaded view
|  
Report Content as Inappropriate

Modizer keeps crashing on boot - HELP! :\

Hi there,

Modizer appears to have a major fault in the 1.2 version. I'm running the app on an iPhone 4 with the latest firmware.

App opens fine when freshly installed - I then transfer my Genesis music via FTP. After this the app seems to work fine for a while, with me listening in the background etc, but today I tried to boot the app up and it sits on the loading screen for a few seconds before crashing back to the phone menu.

I initially thought it might be because I'd set the app to resume playback upon opening (thought this might be confusing things), but it still crashes on me even with this turned off.

Also wondered if I put too much music on there causing app to overload, but I've only got about 30 Genesis soundtracks which used to be fine on previous versions.

I've tried uninstalling everything and uploading the soundtracks again but it's still crashing.

Has anyone experienced this and is there a solution? I'm hoping the next version will address the fault because it's my favourite app ever :(

Thanks
sad_muso sad_muso
Reply | Threaded
Open this post in threaded view
|  
Report Content as Inappropriate

Re: Modizer keeps crashing on boot - HELP! :\

More food for thought here. I transfer music via FTP - I create a new directory called 'Archive' and then put sub directories in this for different consoles (NES, Genesis etc) - at the moment I have just done a fresh install and put 20 Genesis albums on there.

Each Genesis game has it's own directory, and in the directory are the main .vgz files but also one .txt file, one .jpg and one .m3u. This time round I have deleted the last three files and only kept the .vgz - maybe these were confusion Modizer and causing it to crash?
yoyofr yoyofr
Reply | Threaded
Open this post in threaded view
|  
Report Content as Inappropriate

Re: Modizer keeps crashing on boot - HELP! :\

v1.2 has some issues with error management that will be fixed in v1.3. Beta testing has started so it should be available soon.
sad_muso sad_muso
Reply | Threaded
Open this post in threaded view
|  
Report Content as Inappropriate

Re: Modizer keeps crashing on boot - HELP! :\

Thanks - that's great news!

Tried it again today from a clean install - only put 5 MD albums on there. It worked fine for a day, then at random it would crash out on boot screen again. This occurs even after phone reset so the app must be getting critically corrupted. Surprised no one else has mentioned this yet; pretty sure it's not just my phone.

Anyway, bring on 1.3 :D

Thanks
yoyofr yoyofr
Reply | Threaded
Open this post in threaded view
|  
Report Content as Inappropriate

Re: Modizer keeps crashing on boot - HELP! :\

Hi,

I received another report of such crash, I'm trying to find the root cause...

Could you tell me:
- which device & ios version you are using (ex: iPhone 3GS & iOS 3.1.4)
- which files you put in modizer and how/where (using iTunes document folder sharing, ftp client, builtin browser, modland, ...)
- what triggered the crash & when did it occur: before showing the first screen with "Local file/Modland/HVSC/Playlist/..."
- what settings did you changed compared to default (ex: resume playback on, ...)

in fact, I need as much details as possible to try to reproduce the crash issue on my iPhone 3GS or my iPad (currently I have no issue...)
sad_muso sad_muso
Reply | Threaded
Open this post in threaded view
|  
Report Content as Inappropriate

Re: Modizer keeps crashing on boot - HELP! :\

Hi,

Glad to be of help:

- Device: iphone 4
- IOS 4.3.5 (8L1)
- All settings were on default (resume playback off etc)
- I uploaded all files via FTP client. Created a directory called 'Downloads' (in the root, where the 'Samples' directory is) and dropped a load of Genesis soundtrack directories into it (Sonic, Streets of Rage etc etc), then within each directory were .vgz files. I deliberately removed all other files types (jpgs, txts etc) to try and narrow the fault down. I only uploaded 31 soundtracks as wondered if too many were causing a crash, but in the past I've had hundreds in there without a problem
- The crash occurs before showing the first screen (I see the pink intro screen for about 4 seconds (or roughly same time as a normal boot) then it literally shuts app down and I'm back on the iphone's home screen

It's hard to determine exactly when the crash happens - I can use the app a few times and then without any obvious reason it suddenly starts to crash. To test this I have just reinstalled app from fresh and put the 31 soundtracks back via FTP. This was done on evening of 17/08 at 7:30pm GMT. I will continue to use the app under default settings and when I experience a crash I will report back, along with a video to show the fault.






 
sad_muso sad_muso
Reply | Threaded
Open this post in threaded view
|  
Report Content as Inappropriate

Re: Modizer keeps crashing on boot - HELP! :\

Right, it's now 10:46pm and it's already crashed again. Everything was set to default. When I first opened app after fresh install I chose to select all soundtracks, which basically gave me 622 songs in one playlist which I like to listen to on random.

Could this be the issue - too many songs in a playlist? I think the old version of the app was capped at 512 or something, but this new version seems to let you add more but may be causing the crash. Worth noting though that after I had set this playlist up I still managed to close and reopen app fine about 4 times before it randomly crashed in the usual manner. Restarting the app or turning phone off and on again still won't resolve the issue.

Tomorrow I will do another fresh install and this time avoid playing lots of tracks in a huge playlist - if it still crashes then we can probably rule that out.

yoyofr yoyofr
Reply | Threaded
Open this post in threaded view
|  
Report Content as Inappropriate

Re: Modizer keeps crashing on boot - HELP! :\

hi,
thanks for the feedback. I think I found at least one of the possible issue and fixed it for v1.3
sad_muso sad_muso
Reply | Threaded
Open this post in threaded view
|  
Report Content as Inappropriate

Re: Modizer keeps crashing on boot - HELP! :\

No problem.

Here's a clip of what's happening:

http://www.youtube.com/watch?v=w8eSXwB233w

I've now reinstalled but will not play all songs, just one soundtrack at a time and see what happens.

sad_muso sad_muso
Reply | Threaded
Open this post in threaded view
|  
Report Content as Inappropriate

Re: Modizer keeps crashing on boot - HELP! :\

Bad news - crashed again today with all settings on default and only playing one soundtrack.

Is there any possibility at all that it could be due to connecting headphones? I only ask as the last time it crashed was just after I'd hooked the iPhone up I my car stereo via the headphone socket, and this happened again today!
sad_muso sad_muso
Reply | Threaded
Open this post in threaded view
|  
Report Content as Inappropriate

Re: Modizer keeps crashing on boot - HELP! :\

Okay, another fresh boot - this time I only downloaded a few songs from the internet feature within the app and it's still crashed. I'll wait until the next update and see what happens then - at the moment the app is proving unusable for me :(

Thanks for looking into this!
yoyofr yoyofr
Reply | Threaded
Open this post in threaded view
|  
Report Content as Inappropriate

Re: Modizer keeps crashing on boot - HELP! :\

Hi,
V1.3 is available. Can you update and tell me if the issue is fixed?
sad_muso sad_muso
Reply | Threaded
Open this post in threaded view
|  
Report Content as Inappropriate

Re: Modizer keeps crashing on boot - HELP! :\

Hi,

Excellent news! I will download and test this evening.

Thanks for all your hard work and support.
sad_muso sad_muso
Reply | Threaded
Open this post in threaded view
|  
Report Content as Inappropriate

Re: Modizer keeps crashing on boot - HELP! :\

Hi!

I'm happy to report that so far the app is fine! Have had a couple of crashes on boot but when I try again it opens fine! Seems to pop up asking if I want default settings every time now - this seems to be avoid the crash!

Will report back in any updates, but excellent work! :)
Loading...